通达信操盘线指标副图源码

N:=4;

操盘线:SAR(N,15,5),CIRCLEDOT,LINETHICK0;{白色版};

IF((操盘线>=HIGH),操盘线,DRAWNULL),CIRCLEDOT,COLORGREEN;{彩色}

IF((操盘线<=LOW),操盘线,DRAWNULL),CIRCLEDOT,COLORRED;{彩色};

线15:EMA(C,15),COLORBLUE,LINETHICK2;

IF(线15>=REF( 线15,1),线15,DRAWNULL),COLORMAGENTA,LINETHICK3;

IF(线15<REF (线15,1), 线15,DRAWNULL),COLORWHITE,LINETHICK3;

AA05:MA(C,5),COLOR0099CC;

率:=(C-AA05)/AA05*100;

BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;

STICKLINE(BB05>30 AND AA05>REF(AA05,1), AA05,REF(AA05,1),5,1),COLORRED;

STICKLINE(BB05<30 AND AA05<REF(AA05,1), AA05,REF(AA05,1),5,1),COLORWHITE;

顶:DMA(AMOUNT/(95*VOL),VOL/CAPITAL)COLORRED;

中:DMA(AMOUNT/(125*VOL),VOL/CAPITAL)COLORLIGREEN;

底:DMA(AMOUNT/(180*VOL),VOL/CAPITAL)COLORLIRED;

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VAR12:=(HIGH+LOW+CLOSE)/3;

VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR18:=100-ABS(VAR17);

VAR19:=IF(VAR18<90,VAR18,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<130;

VAR2C:=VAR1A<40 AND VAR1B<80 AND VAR19<130;

DRAWTEXT(VAR2C AND COUNT(VAR2C,30)=1,顶,"洗盘"),LINETHICK1,COLORYELLOW;

STICKLINE(VAR2C AND COUNT(VAR2C,30)=1,顶,底,5,0),COLORYELLOW;

DRAWTEXT(CROSS(AA05,中) AND (AA05> 中),中,"拉升"),COLORLIRED;

N1:=7;

LC:=REF(CLOSE,1);

X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORYELLOW,LINETHICK1;

AA:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;

BB:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),1,X),COLOR00FF00;

TJ0:=X=BB;

TJ1:=X=AA;

TJ2:=X<REF(X,1);

TJ3:=X>REF(1,X);

JRS1:=DRAWICON(TJ1 AND TJ2,X,1);

JRS2:=DRAWICON(TJ0 AND TJ3,X,2);

DRAWICON(FILTER(JRS1>0,1),L*0.97,1);

DRAWICON(FILTER(JRS2>0,1),H*1.02,2);

{公式在线提供:www.gszx.com.cn}

免责声明:本文仅代表文章作者的个人观点,与本站无关。其原创性、真实性以及文中陈述文字和内容未经本站证实,对本文以及其中全部或者部分内容文字的真实性、完整性和原创性本站不作任何保证或承诺,请读者仅作参考,并自行核实相关内容。

http://www.pinlue.com/style/images/nopic.gif
分享
评论
首页